PagSeguro Transparente e OneStepCheckout Brasil

Pude observar em algumas instalações de Magento 1.9.x.x, com PagSeguro transparente, usando catão de crédito (boleto funciona normalmente) temos um erro no var/log/pagseguro.txt que é:

08/03/2018 18:16:42 PagSeguro.DirectPayment.CreditCard[error]:

<?xml version=”1.0″ encoding=”ISO-8859-1″ standalone=”yes”?>
<errors><error><code>53037</code><message>credit card token is required.</message></error></errors>

Desabilitando o OSC Brasil 6.0 o erro não acontece, mas como preciso do OSC instalado fui postar o erro na “comunidade.pagseguro.uol.com.br” e não tive resposta, procurando uma solução, pude achar um módulo do Ricardo Martins que implementa o cartão transparente com o PagSeguro.

Módulo em: https://github.com/r-martins/PagSeguro-Magento-Transparente

Site em: http://r-martins.github.io/PagSeguro-Magento-Transparente/

Então em algumas lojas deixei apenas o boleto do Pagseguro ativo e o módulo do Ricardo Martins, tudo funcionando.

Espero que a dica tenha ajudado.

Alfredo Letti

Captcha para formulário de contato do Magento

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *